Problems with Xbox App for PC


Recommended Posts

Hello! Sorry that my first post on this forum is about an issue. It’s a great game that deserves a lot of credit!

But I have had a lot of issues lately on PC via the Xbox App.

It started last fall when I couldn’t get the 2.25 update via the app. It didn’t say it needed an update or anything. So I tried reinstall the game, and I got the newest version.

But since then the 2.26/27 updates have arrived. I now have the same issue, neither the Xbox app MS store shows these updates. I tried the same with a reinstall, but it won’t work. I also tried all other solutions out there on MS/Xbox support, Reddit, and gone through this forum. But non of the solutions work.

I also contacted Xbox support directly via phone a few days ago. The agent told me that Hinterland probably haven’t updated the game on the servers. And he assured me that the latest Xbox/ms store version is 2.25.

Hehe, I then tried turning on my Xbox for the first time in a few years, and guess what..: it has the 2.27 version.😂

So then I thought I could just play from the Xbox on my pc. But… now the DLC that I also bought in the Xbox app a few days ago to try fix the 2.25 to 27 issue won’t show up as owned in the store on Xbox..

Again, I’m sure everything else is up to date, I have logged in with the same ms account everywhere, and all solutions online has been tried and tested. (Even a reinstall of windows 11)
 

Anyone here who experienced the same?

Thanks!

  • Upvote 2
Link to comment
Share on other sites

1 hour ago, mr.bubz said:

Anyone here who experienced the same?

Yeah, there is another thread about an issue with the XBox Play Anywhere not recognizing that the DLC was purchased. I haven't used Play Anywhere for a bit, since I own the game on PC and on XBox, and got tired of transferring saves back and forth- I just have separate saves on each now.

File a bug report and give them the details. I hate to swamp them with reports, but it will let them see how widespread the issue is, with the DLC and updates not being applied.

  • Upvote 2
  • Like 1
Link to comment
Share on other sites

Thanks for the quick replies!💪🏽

But can someone confirm that the 2.27 patch work for Xbox App on PC?

Then I could also try reaching out to the Xbox supporter who said it’s still on 2.25.

And if confirmed, does anyone experience that issue? That the Xbox App won’t show that there is a new patch?😊


Thanks again!

  • Upvote 2
Link to comment
Share on other sites

I just posted about this issue a few weeks ago when the xbox app/Microsoft was requiring me to re-purchase the expansion pack but not the actual game. I can verify that since I have not yet bought the expansion pack, my game version is 2.25 on computer and 2.27 on Xbox but my saves has been compatible. I was able to pick up right where I left off from Xbox to computer without any issues, but I wasn’t in the far territory or anything like that. I was just in a regular area. If you’re playing any DLC content, I’m sure something bad would happen lol. 
 

When I posted about this issue, someone told me that after buying the expansion pack through the Microsoft app (a second time), it suddenly started working, but I can’t verify that myself since I haven’t done it yet. I also contacted Microsoft but so far they’ve been no help. 
 

I do know Hinderland is looking into this issue soon but if you don’t want to wait, you can either buy the expansion pack through Microsoft, which supposedly fixes it. Or you can also play through the cloud through the Xbox app with your Xbox controller and you will have the newest version of the game. It’s only when you install the long dark and play using your keyboard and mouse, that TFT won’t show up. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now