Hard crashing


Recommended Posts

So, I started a new game and was about 2 days in. Found the gun and had the great luck of killing a bear from the porch of one of the cabins on Mystery Lake. Actually, the first shot didn't kill, so I ran in the cabin. As soon as I opened the door, Long Dark crashed.

I restarted, and it saved my location as in the cabin. I stepped outside and the bear was still there, walking slowly toward the shore. Dropped him with a single headshot.

Salvaged some bear meat and hide, back to the cabin, then to a fishing hut to cook some of it. Once I got to the fishing hut, another crash.

Now, I can't start the game. It crashes every time.

Here's the stacktrace from the log file:

AK Error: Voice Starvation
Setting breakpad minidump AppID = 305620
Steam_SetMinidumpSteamID: Caching Steam ID: 76561198035968388 [API loaded no]
AK Error: Event ID not found: 303670379
*** Error in `/home/joel/.local/share/Steam/steamapps/common/TheLongDark/tld.x86_64': double free or corruption (out): 0x00007f850560a4c0 ***

Native stacktrace:

/home/joel/.local/share/Steam/steamapps/common/TheLongDark/tld_Data/Mono/x86_64/libmono.so(+0x91772) [0x7f85e87b6772]
/lib/x86_64-linux-gnu/libpthread.so.0(+0x10340) [0x7f85ee3bf340]
/lib/x86_64-linux-gnu/libc.so.6(gsignal+0x39) [0x7f85ecb82cc9]
/lib/x86_64-linux-gnu/libc.so.6(abort+0x148) [0x7f85ecb860d8]
/lib/x86_64-linux-gnu/libc.so.6(+0x73394) [0x7f85ecbbf394]
/lib/x86_64-linux-gnu/libc.so.6(+0x7f66e) [0x7f85ecbcb66e]
/home/joel/.local/share/Steam/steamapps/common/TheLongDark/tld.x86_64() [0x580f63]
/home/joel/.local/share/Steam/steamapps/common/TheLongDark/tld.x86_64() [0x5782b4]
/home/joel/.local/share/Steam/steamapps/common/TheLongDark/tld.x86_64() [0x473f1a]
/home/joel/.local/share/Steam/steamapps/common/TheLongDark/tld.x86_64() [0x71fe5a]
/home/joel/.local/share/Steam/steamapps/common/TheLongDark/tld.x86_64() [0x72447a]
/home/joel/.local/share/Steam/steamapps/common/TheLongDark/tld.x86_64() [0x7356dd]
/home/joel/.local/share/Steam/steamapps/common/TheLongDark/tld.x86_64() [0x72fc0b]
/home/joel/.local/share/Steam/steamapps/common/TheLongDark/tld.x86_64() [0x730572]
/home/joel/.local/share/Steam/steamapps/common/TheLongDark/tld.x86_64() [0x72b673]
/home/joel/.local/share/Steam/steamapps/common/TheLongDark/tld.x86_64() [0x461f1b]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf5) [0x7f85ecb6dec5]
/home/joel/.local/share/Steam/steamapps/common/TheLongDark/tld.x86_64() [0x46b4ed]

Here's the pastebin for the complete file:


Link to comment
Share on other sites

What distribution are you running? This looks like the issue with an incompatibility between Steam's runtime and the distro provided libraries, to me. If you're on Arch, try starting Steam like this:

LD_PRELOAD='/usr/lib/libstdc++.so.6 /usr/lib/libgcc_s.so.1 /usr/lib/libxcb.so.1' steam

If on Debian or a derived distro, this might help:


Either way, that's probably the issue, and there's probably an equivalent fix for whatever distro you're running.

Link to comment
Share on other sites

System specs: Linux Mint 17.2, Intel i7, nvidia GTX 550 Ti, 16 GB RAM

I've run into this problem already - I'd get an error message about not being able to establish a GLX context / no direct rendering support...

Anyway, I went through several different suggested fixes and eventually overcame it. Looking at the stacktrace I didn't see any of the suspect libraries listed, so I thought I'd post here.

In any case, after rebooting my system, I tried starting LD again. It booted to a black screen. Repeated this twice more and strangely, it works again...

I don't assume the problem's fixed, but it's overcome for the moment.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.