Sign in to follow this  
joki

Mouse sensitivity with new update

Recommended Posts

Hey guys, grats on the update. The performance with unity 5 is just GREAT on my system at first glance! :D

I also really appreciate a way to control the sensitivity when zoomed in. Unfortunately the scales are still ... well not very usefull for me:

- The scale of the normal sensitivity slider is still so high, that the desirable sensitivity for me would be between 2% and 3%, with 2% being too low, and 3% being too high. So why not scale down the slider by x 20 (or change its selectable range from e.g. 1 to 100 to 0.001 to 10000 and give it exponential scale, so everyone can use it no matter what dpi mouse they are using). If i lower the dpi on my mouse, it is really really hard to use the menu UI or alt-tab out of the game and use my second monitor. Like having to move the mouse 3-4 mousepadmeters just to click somewhere. :lol:

- Setting the normal sensitivity to 0% will complete disable mouse look, however gun bob up and such is still enabled

- The scale for the zoomed rifle sensitivity even on 0% is so high, I just ... can't... use it. :| For a moment I thought you just switched 0% and 100%, have a look:

[bBvideo 560,340:2g5jy9lb]

[/bBvideo]

Share this post


Link to post
Share on other sites

It seems that lowering the zoomed sensitivity to 0%, while being still unusable high for me, just adds some "dead"-area. If i move the mouse slowly while zoomed in, it does not move at all. If I move a bit faster than that, it suddenly is crazily fast. There seems to a lot acceleration going on.

Please note that this is NOT something with my mouse driver or windows (I even completely disabled mouse accel via registry settings; there is no other way in win 7 to completely disable it otherwise), and it does not happen in normal mode, only when zoomed in. Please remove the mouse "dead-zone" and accel when zoomed. :)

Share this post


Link to post
Share on other sites

With the last hotfix we removed the mouse acceleration while zoomed, that was unintentionally put in. I was playing around with the mouse settings and had it was 3% and it was really slow. Not sure how slow you like you mouse to be so not sure if that is good for you or not. I like mine at 30% while zoomed, mainly because I like fast sensitivity (Grew on me I guess)

Anyways, I can see if we can tweak it more if you and others still wish to be able to go slower. I'll look into this dead zone as well.

Jeremy

Share this post


Link to post
Share on other sites

Hi Together,

this post has been not used for a long time. But I think I've got something pretty interesting!

I'm using a MacBook Pro Retina with 15" and the dedicated graphics card (mid 2015 Edition), and I was having the same problems with mouse acceleration being ridiculous, and making the game unplayable (during aiming).

My solution (and it is a solution) is:

1. Unplug any kind of mouse that's connected to you Mac.

2. Start the Game TDL.

3. Choose Campaign or Sandbox and start.

4. When the game is loaded and everything seems normal plug your mouse back in.

In my case all the mouse problems where gone and I was able to set my mouse speed up too 50% and aiming speed somewhere between 20% and 30%.

PS: Before I forget to say this, I actually tested this with a Microsoft mouse that didn't have any DPI options, it seemed to work more often even with leaving the mouse plugged in before game start. But for others (in my case the Logitech G300) it worked just fine with the steps above!

I hope this helped a few people, and sorry for my english It's not the best.

Share this post


Link to post
Share on other sites

Grats on the update guys.

V.265:

I have tried this work-around -- which is clearly not a fix for this issue, but a temporary work-around! ;) It does not work on my setup. After I replug the mouse the sensitivity is still crazy. Also in the meantime I happen to have reformatted and resetup my whole computer, and I am using a different mouse now (A4Tech F4 V-Track), which has slightly lower dpi than my old one.

I have all both sensitivity sliders now set at 1% and playing on the 2nd lowest DPI setting on my mouse. The turning speed ingame is kinda okay. Kinda, since I would like the setting to be between 0% and 1% now, which is not available. Again: If you want to use just a slider and not allow numeric value input, just add a slider that lets see any value between 0.0 (zero) and "very-high"), providing continous values and give some logarithmic scale to it. (E.g.: slider at 5% = 0.01 sensitivity, slider at 10% = 0.1 sensitivity, ....) This is not rocket science!

Also with this setting, while the in-game speed is somewhat okay now, when opening inventory, the mouse is so slow, I have to move it to end of the mousepad, lift it up, move it, lift it up, move it, lift it up. This kinda dampenes the gaming experience.

Share this post


Link to post
Share on other sites
Sign in to follow this