Xbox Save Bug - Found a Workaround!

Recommended Posts

Hi all,

For those of you playing on Xbox like me and occasionally experiencing a failure to save (the hatchet icon in the lower right corner not popping up), there is a way to force a save, which I discovered accidentally. I'm not going to say it's foolproof, because I'm no expert in these things, but I did test it 10 times before coming on here to talk about it. This worked for me 100% of the time, but it might not work for you.

A couple weeks ago, my game failed to save after sleeping, and I was about to force quit from the Xbox menu in a rage. However, right before I hit "quit", I noticed the little hatchet appearing on top of the pause screen! I was very surprised... I exited and reloaded the game to check: my progress had been saved!

So here's what I would recommend for my fellow Xbox save bug sufferers: always keep an eye on the autosave icon, and when it doesn't pop, hit the Xbox button, wait a couple seconds (the icon should pop almost instantly), then quit the game and reboot your console. You should be back where you left things.

I also tried a few other times to continue playing after a save hiccup without rebooting the console, and it's been fine, but because I'm paranoid I personally prefer reloading... just to be on the safe side.

Now there's a whole other issue somewhat related to saving that I've been experiencing: sometimes, when you attempt to exit the game from the pause screen (where it says "back to game", "badges", "options", "quit"), selecting "Quit" will bring up the confirmation box as expected, but when you try to click "Yes", the game freezes, preventing you from interacting with it in any way other than from the Xbox menu... and when you relaunch the game, it erases the last successful save and takes you back to the previous one. I am POSITIVE that none of my saves had failed, since I always watch out for the icon. It's a separate issue, it seems.

I do have TFTFT installed, and this may or may not be caused by the DLC, but it should be noted that this issue has happened to me on various older maps as well as newer ones in the Far Territory.

I also found a workaround for this new bug (not as well-tested though, I only tried it once today): instead of quitting the game "from within" as you might instinctively want to do, just quit from the Xbox menu. It worked fine for me, no progress lost. I'll continue testing it over the next couple weeks, and I might post an update.

Thanks for reading, hope this helps someone else!


  • Upvote 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now