Black screen crash - Windows 8.1 (Steam)


Recommended Posts

Hi! I've been trying to play The Long Dark for a couple of hours now but an annoying bug that causes the screen to go to black is hindering my progress. I'm seeing there are many people with the same problem so I'm not sure if my bug report has anything to contribute but I still think it's worth posting because there might be something in my computer specs and log files that might steer the devs in a right way. Perhaps?

The bug has been persistent since I launched the game the first time and occurs every once in a while. There doesn't seem to be any single action that triggers the bug. First couple of times it occurred when I launched the game an "pressed any button" to access Main Menu. When I do manage to start the game and go explore the bug seems to happen when I try to interact with an item or enter a building.

The longest I've manage to play without having to restart the game is maybe 30 minutes – and even during that one "longer" play session I had black screens but I was able to continue by alt tabbing to desktop and then activating the game window again. Now I get this bug when I try to load my save (and I also got "tld.exe has stopped working"). Usually it takes between 5 to 10 minutes of play before I need to restart. I have tried launching the game through tlds_dx9.bat in D:\Program Files (x86)\Steam\steamapps\common\TheLongDark and forcing the DX9 with "-force-d3d9" (without the questions marks as instructed) in Steam's launch options but neither was any help. I've also had to restart my computer a couple of times because of these issues.

Computer specs:

  • Windows 8.1 Pro (64 bit)
  • NVIDIA GeForce GTX 960 (Driver version 361.75)
  • Inter Core i7-4790 CPU @ 3.60GHz
  • 1920 x 1080 display, fullscreen, 144Hz
  • 16.00 GB RAM
  • Gigabyte GA-Z97-D3H motherboard

Steps I've taken while trying to fix this:

  • I have made sure NVIDIA drivers are up to date
  • I have reinstalled Microsoft Visual C++ 2013 Redistributables (both x86/x64)
  • I have reinstalled the game twice (second time because it somehow got deleted after I had to restart my game because of a crash)
  • I have verified game cache multiple times.
  • I have tried launching the game in DX 9 and DX 11 modes / windowed / combination of these.

Nothing works. The screen goes blank and I can hear the sounds for a while, then it's just dead. Sometimes I'm able to alt tab to desktop and kill the game through task manager but sometimes it just tells me that tld.exe has stopped working OR nothing at all happens and I have to power my computer off and restart. Once when I returned to desktop NVIDIA Experience had a notification that said something along the lines "Nvidia display/kernel mode driver (361.75) has stopped working and recovered succesfully", and when I tried to run the game in DX 11 mode, I had an error message with different kind of message (something about C++ I recall. I had a screenshot but couldn't save it because I ended up having to restart my computer again).

I've attached output_log.txt in this comment.


Link to comment
Share on other sites

Hi, and thank you for your attention. I actually emailed my save files and system info as well as a dump file and output_log.txt from the latest crash to couple of days ago. I've forwarded the message to the address that you provided.

Although, since making this thread I've started to suspect that I might actually have a defective GPU. I thought it was strange that none of the workarounds that have been posted here worked for me, so I started checking for the usual suspects of GPU failure. It's not an issue of overheating and my PSU is powerful enough but what I discovered is that the NVIDIA drivers crash whenever I try to run a stress test with FurMark. I tried some fixes that I found from the internet that included changing some settings from NVIDIA control panel, changing advanced power plan settings (was supposed to turn something 'off' which, as it turned out, was already turned off by default) and even editing Windows registry to increase timeout detection window. I contacted NVIDIA support and installed older drivers that they provided. Nothing worked and when I contacted them again they said it sound like that the card is defective.

My GPU card is manufactured by MSI so I contacted their support as well, and they replied that "if the driver stops responding frequently it is usually a hardware issue". And finally, it seems that the drivers have started to crash with any modern 3D game. I played Fallout 4 for hours without any problems back when it was released but now it also crashes to black screen when I try to load a save. Today I also figured I could give Deus Ex a try because a friend of mine liked it. Same thing, it crashes as soon as the opening cutscenes are over and I'm supposed to actually start playing. I see a pattern emerging.

So I guess what I'm trying to say is that after spending the whole week trying to figure out how to fix this problem it's starting to look like the problem is not with the game at all. Why this didn't occur to me earlier is that I had never had this serious problems with my computer. Occasional driver crashes maybe but even those happened outside video games. I suppose because TLD is still in early access and many people were reporting similar problems I just assumed it's an issue with the software.

I've provided the files so you can look into it if you want but it's probably a waste of time because I'm encountering these problems with other games and benchmark software as well. I'm sorry but I seem to have demanded your time for nothing.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.