Setting resolution is borked at the moment?


Shadrach

Recommended Posts

Hey,

in the latest Steam alpha resolution does not seem to work. It seems to just stick with the desktop resolution.

I am trying to run it fullscreen 1920*1200.

Here's the log:

Initialize engine version: 4.5.3f3 (fca41a4fabea)

GfxDevice: creating device client; threaded=1

Direct3D:

Version: Direct3D 9.0c [nvd3dum.dll 9.18.13.3788]

Renderer: NVIDIA GeForce GTX 580

Vendor: NVIDIA

VRAM: 1487 MB (via DXGI)

Caps: Shader=30 DepthRT=1 NativeDepth=1 NativeShadow=1 DF16=0 INTZ=1 RAWZ=0 NULL=1 RESZ=0 SlowINTZ=0

Begin MonoManager ReloadAssembly

Platform assembly: F:\games\Steam\steamapps\common\TheLongDark\tld_Data\Managed\UnityEngine.dll (this message is harmless)

Loading F:\games\Steam\steamapps\common\TheLongDark\tld_Data\Managed\UnityEngine.dll into Unity Child Domain

Platform assembly: F:\games\Steam\steamapps\common\TheLongDark\tld_Data\Managed\Assembly-CSharp-firstpass.dll (this message is harmless)

Loading F:\games\Steam\steamapps\common\TheLongDark\tld_Data\Managed\Assembly-CSharp-firstpass.dll into Unity Child Domain

Platform assembly: F:\games\Steam\steamapps\common\TheLongDark\tld_Data\Managed\Assembly-CSharp.dll (this message is harmless)

Loading F:\games\Steam\steamapps\common\TheLongDark\tld_Data\Managed\Assembly-CSharp.dll into Unity Child Domain

Platform assembly: F:\games\Steam\steamapps\common\TheLongDark\tld_Data\Managed\Assembly-UnityScript-firstpass.dll (this message is harmless)

Loading F:\games\Steam\steamapps\common\TheLongDark\tld_Data\Managed\Assembly-UnityScript-firstpass.dll into Unity Child Domain

Platform assembly: F:\games\Steam\steamapps\common\TheLongDark\tld_Data\Managed\Assembly-UnityScript.dll (this message is harmless)

Loading F:\games\Steam\steamapps\common\TheLongDark\tld_Data\Managed\Assembly-UnityScript.dll into Unity Child Domain

Platform assembly: F:\games\Steam\steamapps\common\TheLongDark\tld_Data\Managed\SampleClassLibrary.dll (this message is harmless)

Loading F:\games\Steam\steamapps\common\TheLongDark\tld_Data\Managed\SampleClassLibrary.dll into Unity Child Domain

Platform assembly: F:\games\Steam\steamapps\common\TheLongDark\tld_Data\Managed\SuperSplines.dll (this message is harmless)

Loading F:\games\Steam\steamapps\common\TheLongDark\tld_Data\Managed\SuperSplines.dll into Unity Child Domain

Platform assembly: F:\games\Steam\steamapps\common\TheLongDark\tld_Data\Managed\Pathfinding.ClipperLib.dll (this message is harmless)

Loading F:\games\Steam\steamapps\common\TheLongDark\tld_Data\Managed\Pathfinding.ClipperLib.dll into Unity Child Domain

Platform assembly: F:\games\Steam\steamapps\common\TheLongDark\tld_Data\Managed\Ionic.Zip.Reduced.dll (this message is harmless)

Loading F:\games\Steam\steamapps\common\TheLongDark\tld_Data\Managed\Ionic.Zip.Reduced.dll into Unity Child Domain

Platform assembly: F:\games\Steam\steamapps\common\TheLongDark\tld_Data\Managed\Pathfinding.Ionic.Zip.Reduced.dll (this message is harmless)

Loading F:\games\Steam\steamapps\common\TheLongDark\tld_Data\Managed\Pathfinding.Ionic.Zip.Reduced.dll into Unity Child Domain

Platform assembly: F:\games\Steam\steamapps\common\TheLongDark\tld_Data\Managed\Pathfinding.JsonFx.dll (this message is harmless)

Loading F:\games\Steam\steamapps\common\TheLongDark\tld_Data\Managed\Pathfinding.JsonFx.dll into Unity Child Domain

Platform assembly: F:\games\Steam\steamapps\common\TheLongDark\tld_Data\Managed\Pathfinding.Poly2Tri.dll (this message is harmless)

Loading F:\games\Steam\steamapps\common\TheLongDark\tld_Data\Managed\Pathfinding.Poly2Tri.dll into Unity Child Domain

Platform assembly: F:\games\Steam\steamapps\common\TheLongDark\tld_Data\Managed\DecalSystem.Runtime.dll (this message is harmless)

Loading F:\games\Steam\steamapps\common\TheLongDark\tld_Data\Managed\DecalSystem.Runtime.dll into Unity Child Domain

- Completed reload, in 0.079 seconds

Initializing input.

Input initialized.

desktop: 1280x720 60Hz; virtual: 2720x900 at 0,0

Platform assembly: F:\games\Steam\steamapps\common\TheLongDark\tld_Data\Managed\System.Core.dll (this message is harmless)

Platform assembly: F:\games\Steam\steamapps\common\TheLongDark\tld_Data\Managed\System.dll (this message is harmless)

Platform assembly: F:\games\Steam\steamapps\common\TheLongDark\tld_Data\Managed\UnityScript.Lang.dll (this message is harmless)

Platform assembly: F:\games\Steam\steamapps\common\TheLongDark\tld_Data\Managed\Boo.Lang.dll (this message is harmless)

UnloadTime: 6.050321 ms

WwiseUnity: Initialize sound engine ...

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

WwiseUnity: Sound engine initialized.

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

Successfully initialized Steam!

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

Platform assembly: F:\games\Steam\steamapps\common\TheLongDark\tld_Data\Managed\System.Xml.dll (this message is harmless)

Unloading 7 Unused Serialized files (Serialized files now loaded: 0 / Dirty serialized files: 0)

Unloading 3217 unused Assets to reduce memory usage. Loaded Objects now: 6809.

Total: 17.201431 ms (FindLiveObjects: 0.963627 ms CreateObjectMapping: 0.141688 ms MarkObjects: 12.849567 ms DeleteObjects: 2.577865 ms)

Steam Leaderboard found: True, error: False

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

Received stats and achievements from Steam

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

Fallback handler could not load library F:/games/Steam/steamapps/common/TheLongDark/tld_Data/Mono/libc

Fallback handler could not load library F:/games/Steam/steamapps/common/TheLongDark/tld_Data/Mono/.\libc

Fallback handler could not load library F:/games/Steam/steamapps/common/TheLongDark/tld_Data/Mono/libc

Link to comment
Share on other sites

Yes windowed mode works fine. Actually it appears Fullscreen has no effect - if I choose Fullscreen 1920x1080 I just get a full-window 1280x720, my desktop res.

Two monitors, but running fullscreen on only one of them. This used to be working in the earlier alphas but unsure.

Link to comment
Share on other sites

The registry settings at:

HKEY_CURRENT_USER\Software\Hinterland\The Long Dark

are always reset to 1280x720

Screenmanager Is Fullscreen mode_h3981298716 = 1

Screenmanager Resolution Height_h2627697771 = 720

Screenmanager Resolution Width_h182942802 = 1280

Editing these values manually just leads to them being reset.

I have tried uninstalling, deleting install folder and AppData\LocalLow\Hinterland and still the same.

Link to comment
Share on other sites

Yes, I can change my resolution to lower, and it changes (at very low it just blurs badly), but it does not change the monitor resolution at all, just the game resolution.

In fact, I can change my desktop resolution to 1920x1080, and the the game will run at that res but it's still not full-screen, it's a borderless window.

Seems it always defaults to running the game in the desktop resolution. Maybe you are not able to repro because you are running the same res. Try setting a lower desktop res than the game and see if the monitor actually changes its display when starting the game.

I know it was working on 23/8 because I have a screenshot taken at 1920x1200 in Steam. So some time between there and today something changed.

Link to comment
Share on other sites

OK, I confirmed the situation where the game seems to cap the resolution to desktop res when running fullscreen (even though the choices displayed offer higher resolutions). Will fix this asap.

What makes you say you are getting a borderless window when you run fullscreen though? The only way for the game to run with a borderless window is if you launch the game as:

tld -popupwindow

Link to comment
Share on other sites

It appears this is a new bug in Unity, as we are making the correct call to set the resolution, but it's not actually changing anything. We upgraded to the most recent version of Unity for this update, so that fits with things working for you on 8/23. We'll be following up with Unity to get this addressed.

Link to comment
Share on other sites

Thanks Alan! I know my way of running low desktop and higher in game is kind of rare, and so I guess a lot of people don't notice this bug at all.

Borderless window - that was a misnomer, it was actually full-screen but behaved like a window since it was the same res as desktop :)

Link to comment
Share on other sites

  • 3 weeks later...
  • 2 months later...
  • 1 month later...

Setting the cmdline didn't work I'm afraid.

What I am doing now is this, which is a mess but at least works temporarily.

In a bat file:

@echo off

"D:\bin\Nirsoft Launcher\NirSoft\nircmd.exe" setdisplay 1920 1200 32

f:\games\Steam\steam.exe -applaunch 305620

pause

"D:\bin\Nirsoft Launcher\NirSoft\nircmd.exe" setdisplay 1440 900 32

Link to comment
Share on other sites

  • 3 months later...

Not forgotten about. but... Unity might have forgotten. Looked back at this post it was from a while ago on Unity 4. We are on 5 now and you'd thing they'd have fixed this. I'll make a note of this for Alan and see if we can press Unity for it. We still waiting on the shadows too, which are very borked.

Jeremy

Link to comment
Share on other sites

Thanks for the update Jeremy, much appreciated!

This Unity 'bug' or what it is is getting to the point where I'm sceptical of buying Unity games since I know almost all of them will display this same behavior. Games that have the same problems include Sunset, Hot Tin Roof and Shelter 2. The Shelter 2 developers Might & Delight actually fixed it, not sure what they did, and the Sunset dev said they would contact them for more information.

I wonder - if you could re-enable the config dialog either with pressing Alt on launch or with "-show-screen-selector", possibly that could work to set the resolution permanently?

Link to comment
Share on other sites

I can't reproduce this behavior. If anyone else has this happen -- please follow up here.

Following up here. Please note that this is still from version V.228 (running unity 4?). I will try it again tomorrow or so if the behaviour is unchanged. The crash however is a different issue and happens only when using a screen capturing tool like fraps.

Link to comment
Share on other sites

  • 5 months later...

Hello again,

just checking in to see if there's any update on this issue? I'd really like to stop using my bat file workaround some time :)

Also, if you guys have any information from Unity about the issue please let me know if you can, it seems this affects almost every single Unity game I play these days, and some information would be really helpful to let other developers know a bit about what is wrong.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.