dutch tdk

Computer restarts randomly

Recommended Posts

So every now and then (15 minutes to an hour in real world time) my PC suddenly shuts off. Just a black screen and fans that stop spinning. no "windows is shutting down" message or anything, like someone unplugs the power.

After a few seconds everything starts up again.

This happens in game and only in this game.

The restarts seem pretty random, it doesn't happen when transitioning to another area, nor when I pick up items or using an action. Neither does it happen when I'm visiting a named location in the area.

The crashes mostly happen when I'm just walking or idling.

I'm on PC with windows 8.1 and the latest steam version.

I have no clue on how to repeat these events besides just playing the game and waiting 30 minutes till the next random restart

once every few restarts the save file disapears and I have to start at day one again, the disapearance happens once every 10 times or so.

----------------------------------------------------

Things I've tried:

  • Checking Temperature of hardware (45 degrees celcius was the max that was achieved)
  • Updating drivers. didn't work
  • Verify integrity of cache files. they were fine
  • Cleared my SSD so 2GB of space increased to 60GB. again, didn't work
  • shut down all other applications
  • Tested it with other, more and less demanding games including but not limmited to: batman arkham knight, Minecraft and borderlands. all of whom run just fine without any restarts

Sorry for the lack of specific information but I myself have no clue what makes these crashes happen

Share this post


Link to post
Share on other sites

Seems like you did most of the things I can think of already. Did you check the temperature of the graphics card as well (I assume the 45c is for the CPU)?

You could try reinstalling but I doubt it would do much as you already verified the game files.

Share this post


Link to post
Share on other sites

Speaking of Temps and random crashes...

In the past I've had several Systems with Stability-Problems caused by overheating of North- and/or Southbridge Chips.

Could be worth checking these too...just to be sure.

Share this post


Link to post
Share on other sites

If we're considering heat problems, then this issue should also be reproducible in other games. At least, I don't recall TLD using a particularly high amount of memory or CPU cycles to run, so if that's what's doing it, other higher-graphics games would also trigger a restart. If nothing else I'd be curious to see what the performance monitor is recording when the issue occurs.

Only other suggestion I have is to share config info and collect windows logs. I recommend:

A) open up msinfo (on win 8 and win 10 just click the start menu and type in 'msinfo'. I think on Win 7 it's 'msinfo32'. Share a screenshot of the System Summary, it'll include CPU, OS build, RAM, etc.

B) reproduce the issue again, and then opening Event Viewer (On win 10 and 8 you can right-click the start menu and it will be an option there. On win 7 you might have to search for Event Viewer). Under Windows Logs there's a System option. click it and you should quickly find messages about an "unexpected restart" or the like, it may even contain information about what process caused the restart.

Share this post


Link to post
Share on other sites

So you're actually playing the game or are you alt tabbed? The Long Dark seems to usee 100% of gpu when you are alt tabbed, unless it was fixed.

Share this post


Link to post
Share on other sites
If we're considering heat problems, then this issue should also be reproducible in other games.

You would think so, but not necessarily. It could also be linked to a specific technique used by TLD. But I agree that that is not very likely.

So you're actually playing the game or are you alt tabbed? The Long Dark seems to usee 100% of gpu when you are alt tabbed, unless it was fixed.

Last time I played I switched to chrome to look up an email for my wife and I noticed the noise my computer was making increased after a short while; the fans on the GPU were spinning up. So I don't think this is fixed.

One other thing you could try is using older drivers for your GPU. Sometimes new drivers can cause a problem.

Share this post


Link to post
Share on other sites

e661830e8b9e48fed406c21eed5b3fdb.png

Here is my msinfo.exe info,

excuse me for it being in dutch. I hope it can help. furthermore it definately isn't a heat issue. everything runs bellow 50 degrees inclusding the north and southbridge chipsets

also excuse me for reacting so late

I play the game fullscreen and don't alt tap, and when I play windowed it crashes too. at lower resolutions the same happens.

lastly the windows logs only say that the pc shut down unexpected because it stopped reacting, froze or lost power

Share this post


Link to post
Share on other sites

I did forgot to tell that my windows is still windows 8 and not 8.1. A copy of windows I cannot upgrade to 8.1 because it may or may not me an illegal version of windows. Anyway I've received a fully legitimate key/ISO for windows 8.1 from my school. so once I get my hands on a DVD to burn it on (since my motherboard doesn't support installing windows from a usb), I'll try the game on 8.1.

I'll post my results here in a week or two and if everything works out we could conclude one of the following:

1. Somehow the illegal version of windows prevented me from playing this single game out of 40+ games, which is unlikely.

2. The game can't work with windows 8 but can work with windows 8.1

3. Reinstalling windows fixed the problem in some way or the other

Share this post


Link to post
Share on other sites

Sadly it hasn't turned out better, I still get crashes randomly while I got a legitimate version of windows 10. A clean install

Share this post


Link to post
Share on other sites

Looks like you've tried all of the obvious things, sorry that this isn't resolved yet.

The only other thing that jumps out at me is the graphics card, but only because it doesn't look too familiar to me. Your system looks more than capable of handling the minimum requirements of the game (except disk space? I don't think that's listed but I assume it would have come up by now)

My only other contribution is, though those 40+ other games may be running fine, TLD is still in Alpha (I don't know how many of those other games are/aren't in Alpha). Maybe this is the first time a configuration like yours has been tested, so there isn't support for it yet. But I can't say for sure, and even if that was the case I don't know what you'd do about it. Sorry :/

Share this post


Link to post
Share on other sites

The lack of disk space was the first thing that concerned me. It was an obvious point since I only had 2GB left on my SSD. Clearing it didn't work. However you did give me an idea to install the game on My HDD.

Maybe it will work on a normal HDD or maybe my SSD is faulty

Share this post


Link to post
Share on other sites

Check the event viewer in Windows the next time this happens or if you know approximately the time and date it happened in the past. Start->Run (or Windows key+ R) and type compmgmt.msc then hit enter.

This should bring the Computer Management console up. Expand the event viewer category, expand custom views, then click on Administrative Events. It may take a minute or two to load the log.

If you know the date and time when the loss of power occurs, you can see if Windows is logging any errors prior to or after the event. If there is an error code, especially on an event with Bugcheck, this can be useful for narrowing down the cause.

Alternatively, in the C:\Windows folder or the C:\Windows\minidump folders you may find crash dumps with modified or created timestamps that coincide with the crash(memory.dmp or %datetime%.dmp, respectively). If you get the Windows Debugging Tools and open these crash dumps it'll usually point to the problem.

Windows Debug Tools are available here: https://msdn.microsoft.com/en-us/librar ... 63(v=vs.85).aspx

Start the SDK installer, customize by turning off the other features other than the Debugging Tools.

Open the Debugging Tools, use File->open a crash dump, navigate to the folder with your .dmp file and open the dump. Without symbols loaded, the crash analysis may not be accurate, so you may have to load them. See https://msdn.microsoft.com/en-us/librar ... 00(v=vs.85).aspx for commands.

The debugger will have a link for !analyze -v which will give you verbose information on the crash. Usually googling the driver/whatever that is found to be the problem will lead to useful information.

If there are no .dmp files, Bugchecks in the log, etc and this truly is a sudden loss of power, then the power supply may be suspect or the electrical line quality may be a factor. Given your description of only happening while playing TLD, I have to suspect this will be a driver issue of some sort.

Hope that helps, sorry for any typos as I'm on a tablet, and good luck!

Share this post


Link to post
Share on other sites

Alternately, if you have a MEMORY.DMP file to look at, I actually just got some training on reading MEMORY.DMP files with windbg. If you don't want to go through setting up the debugger yourself (It's not too difficult but can take some time and can use up a chunk of disk space), I'm more than willing to do it.

Share this post


Link to post
Share on other sites

Is this a laptop computer? Those are notorious for glitchy power supply issues. It sure sounds like some sort of H/W problem and the best advise seems to be to use the windows tools to see what is going on. Be aware that a hardware problem is going to cause all sorts of software failures too.

Share this post


Link to post
Share on other sites