wyrdsmyth

[solved] v.284 Crash on entering trapper's cabin

Recommended Posts

Currently playing in Arch x64 (I am aware that Steam on Arch is not officially supported) with open source Radeon drivers.

This was a brand new game, first one attempted in linux. I chose random and started in Mystery Lake, relatively close to the trapper's cabin, made my way there, picked up some wood and twigs on the way, and the game crashed with no error when I clicked on the door to the cabin.

Feel free to point me to anything you'd like from tld_Data or elsewhere and I'll be happy to upload it.

Edit: When time permits I will try again with proprietary drivers

Edited by Guest

Share this post


Link to post
Share on other sites

I'm also on Arch. I seem to have resolved that issue today, though. What I did is launch Steam like this:

LD_PRELOAD='/usr/lib/libstdc++.so.6 /usr/lib/libgcc_s.so.1 /usr/lib/libxcb.so.1' steam

I'm fairly sure the problem is gone, but of course, I could be getting really lucky. I entered and exited a cabin for about 20 minutes in a test save with no crashes, then played for a while normally, though, so looking good.

I got the info from here:

https://wiki.archlinux.org/index.php/St ... leshooting

There's also instructions on how to edit the .desktop file (it's in /usr/share/applications/steam.desktop) to make that permanent on that page. I have not made sure it doesn't mess up other games, though. Probably not, but...

Seems to be an issue with libraries and the steam runtime. I posted other info on this in another similar thread in this sub-forum. If this resolves it for you, as well, I'm sure we'd love to know (one way or another). Hope that gets you going!

Share this post


Link to post
Share on other sites
I'm also on Arch. I seem to have resolved that issue today, though. What I did is launch Steam like this:

LD_PRELOAD='/usr/lib/libstdc++.so.6 /usr/lib/libgcc_s.so.1 /usr/lib/libxcb.so.1' steam

I'm fairly sure the problem is gone, but of course, I could be getting really lucky. I entered and exited a cabin for about 20 minutes in a test save with no crashes, then played for a while normally, though, so looking good.

I got the info from here:

https://wiki.archlinux.org/index.php/St ... leshooting

There's also instructions on how to edit the .desktop file (it's in /usr/share/applications/steam.desktop) to make that permanent on that page. I have not made sure it doesn't mess up other games, though. Probably not, but...

Seems to be an issue with libraries and the steam runtime. I posted other info on this in another similar thread in this sub-forum. If this resolves it for you, as well, I'm sure we'd love to know (one way or another). Hope that gets you going!

Just a quick update, that seems to have worked for me as well. I did also upgrade to proprietary drivers, especially after I noted that open source ATI drivers are an issue, but it was not until I used the LD_PRELOAD that the crashes stopped. Thanks again!

Share this post


Link to post
Share on other sites
Thanks for helping Addle :)

We Canadians like to be helpful, right, eh? :)

You're welcome, and thanks for supporting Linux!

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.