Sign in to follow this  
Procrastinator MEDIC

[solved] Game Not Loading

Recommended Posts

I have played a lot of The Long Dark and was saddened to attempt to load it one day and be greeted by a black screen with no indication of the game loading anything.

here is the specs I got from the output log:

Initialize engine version: 5.0.2f1 (0b02744d4013)

GfxDevice: creating device client; threaded=1

Direct3D:

Version: Direct3D 11.0 [level 11.0]

Renderer: Intel® HD Graphics 4600 (ID=0x416)

Vendor: Intel

VRAM: 874 MB

Share this post


Link to post
Share on other sites

could you try verifying you game cache integrity if you haven't tried already.

Go to your steam library

Left click on The Long Dark

Select "Properties"

Select the "Local Files" tab

Press "verify integrity of game cache"

Jeremy

Share this post


Link to post
Share on other sites

could you try running this and see if the game works afterwards.

In Steam interface, click on "LIBRARY".

In games list, right click on "The Long Dark".

Choose "Properties"

Click "SET LAUNCH OPTIONS..."

Paste into text box "-force-d3d9" without the quotes

Click "OK".

Click "CLOSE".

I've heard that the Intel Graphics 4600's don't run DirectX 11 very well so it might be good to try in DirectX 9 instead. So give this a try and let me know if this works at all.

Jeremy

Share this post


Link to post
Share on other sites

I am not sure on how to do the DirectX 9 thing but here are my computers specks

OS Name Microsoft Windows 8

Version 6.2.9200 Build 9200

Other OS Description Not Available

OS Manufacturer Microsoft Corporation

System Name JACOB

System Manufacturer Hewlett-Packard

System Model HP Pavilion 17 Notebook PC

System Type x64-based PC

System SKU E0J97UA#ABA

Processor Intel® Core i3-4000M CPU @ 2.40GHz, 2400 Mhz, 2 Core(s), 4 Logical Processor(s)

BIOS Version/Date Insyde F.14, 10/4/2013

SMBIOS Version 2.7

Embedded Controller Version 96.37

BIOS Mode UEFI

BaseBoard Manufacturer Hewlett-Packard

BaseBoard Model Not Available

BaseBoard Name Base Board

Platform Role Mobile

Secure Boot State On

PCR7 Configuration Binding Not Possible

Windows Directory C:\WINDOWS

System Directory C:\WINDOWS\system32

Boot Device \Device\HarddiskVolume2

Locale United States

Hardware Abstraction Layer Version = "6.2.9200.16442"

User Name Jacob\JACOB\Jacob

Time Zone Pacific Daylight Time

Installed Physical Memory (RAM) 4.00 GB

Total Physical Memory 3.92 GB

Available Physical Memory 2.01 GB

Total Virtual Memory 7.29 GB

Available Virtual Memory 4.09 GB

Page File Space 3.38 GB

Page File C:\pagefile.sys

Hyper-V - VM Monitor Mode Extensions Yes

Hyper-V - Second Level Address Translation Extensions Yes

Hyper-V - Virtualization Enabled in Firmware No

Hyper-V - Data Execution Protection Yes

Share this post


Link to post
Share on other sites
I am not sure on how to do the DirectX 9 thing

He gave you the instructions to run the game in DirectX, so you'll be able to follow the steps easily. It will hopefully solve some or all of the issues as a workaround for your graphic chip for now

In Steam interface, click on "LIBRARY".

In games list, right click on "The Long Dark".

Choose "Properties"

Click "SET LAUNCH OPTIONS..."

Paste into text box: -force-d3d9

Click "OK".

Click "CLOSE".

Share this post


Link to post
Share on other sites
ok I did that and it still is not doing anything the popup that says I can access the steam community works but other than that nothing happens sorry if I am being difficult

No worries :) This is what we are here for! Could you please post your "output_log.txt"? It can be found at C:\TheDirectoryYouInstalledSteamTo\steamapps\common\TheLongDark\tld_Data\output_log.txt

Melody~

Share this post


Link to post
Share on other sites

You can attach the file as an attachment in a post here. so no need to copy and paste it into a reply. This way I can just download the file from the post instead of scrolling down a huge reply. If you reply using the Full Editor instead of quick reply, you can add attachments to your post.

Jeremy

Share this post


Link to post
Share on other sites

That was the right one thanks.

Also that immediately told me what the real problem was. The problem is that Steam didn't install the Visual Studio C++ redistributable package required to play the game. You'll need to install it manually from Microsoft here: https://www.microsoft.com/en-ca/downloa ... x?id=40784

When installing the package remember to install the one that is for your Operating System. the x86 package is for 32 Bit Operating Systems, and the x64 package is for 64 Bit Operating Systems. If you are unsure of which your operating system is you can find that info out by going into your Control Panel > System & Security > System.

Jeremy

Share this post


Link to post
Share on other sites
Sign in to follow this