Dancing colorful dots - cannot see almost anythin


Recommended Posts

Hi there,


I have just started up TLD after a few months of not playing it. I have the latest macbook Pro with Catalina v 10.15 on it. When I run the game the first few frames work fine, however when I get to the game start menu the background is dancing colorful dots (see screenshot). How can I solve this issue?





Link to comment
Share on other sites

I have the same issue on my MacBook Pro but I have this game on Epic Games. Could anyone help me? :(


Edit#1 I've just added on additional command-line arguments in options this command that shmoo recommend. Thanks a lot!

Edited by madix7
  • Upvote 1
Link to comment
Share on other sites

  • 2 weeks later...
On 12/23/2020 at 7:45 PM, shmoo said:


Try adding 


to the Set Launch Options of the game in Steam.

I have this issue too on macOS Big Sur. Seems to have started around the launch of Hesitant Prospect update (v.189).

Wow, this has solved it! Thank you so much

Link to comment
Share on other sites

A similar problem exists in certain areas under the linux proton environment, and can lead to the game freezing. Very annoying. Yes, it started in linux with Hesitant Prospect as well. It appears differently than it does in Mac, but is similar enough that I suspect its a similar source. Unfortunately, a bug in TLD/Unity makes "-force-glcore" a non starter, as the landscape flickers to an insane extent when using the opengl backend under linux; it /appears/ that this is a known problem but I suspect it's been placed into "will not fix". Running the windows version under Proton and its ability to convert directx calls to vulkan calls make the flickering landscape into a non-issue, but now I see periodic instability. @Admin if you're interested it appears to be triggered extensively in Ash Canyon, and also in the Echo Ravine in TWM; in short where the deep shadows/misty areas are lead to the game going unstable and then punching out.

Link to comment
Share on other sites

Guest jeffpeng

This is interesting, as I cannot confirm that this bug happens on Mac OS Catalina and Big Sur with a Radeon 390 (which requires some kext hackery to work - but it works). It also does not with the new M1 Macs, which, obviously, only run Big Sur.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now