Loading screen freezes


Recommended Posts

Today I loaded my survival game and everything seemed to work pretty fine until I tried to travel from Bleak Inlet to Ravine. Loading screen froze and I was forced to close the game using the task manager. I then rebooted the game and when I tried to load the game the loading screen froze again. Now it seems I can't load my survival game. This is the first time I experience this kind of problems. Is it only me?

I verifyed game cache and updated my NVIDIA graphics drivers, nothing seemed to work. I would reinstall the game, but even knowing the game uses Steam cloud I'm just too afraid to lose my entire survival game :hatchet:

Edited by Danielviomusic
Link to post
Share on other sites

Two days now of not being able to pass any loading screen, after couple of days being able to pass "some" of them. None of the Hinterland suggestion workarounds are working either for me so yes, this is even worse than when these same things started occurring after the Fearless Navigator update (were fixed for Winter's embrace). The next hotfix can't come soon enough, I just pray we don't have to wait until the December update to, you know, just be able to play the game at all...

Edited by Mistral
Link to post
Share on other sites

I read elsewhere that some folks were having success running it under the Admin account. Maybe try that? Could be a weird writing permissions issue of some kind, though that said it's been working for me... my problems were all with the initial EtDW build, not the fixed one that came out a couple of days after its initial release.

 

Link to post
Share on other sites
2 hours ago, stratvox said:

I read elsewhere that some folks were having success running it under the Admin account. Maybe try that? Could be a weird writing permissions issue of some kind, though that said it's been working for me... my problems were all with the initial EtDW build, not the fixed one that came out a couple of days after its initial release.

 

Hm.. Even inside certain builds I've had days on non-crashing and total-crashing, so this seems unlikely for me. Anyway they have just released hotfix 1.88, have to check out if it fixes things (the changelist mentions nothing of sort, but you never know)

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now