Currently TLD gave error in Steam Re-downloading Steam >_<


TattooedMac

Recommended Posts

I woke this mining to see Changelog for .v0.4 and downloaded n worries through steam. Then went to play it and gave me a error that I can't play, because TLD.app is already open. Had no icon in m dock, so quit steam and tried again, and got the message as seen in the image.

So I went through ALL the Steam recommendations of what to delete like the apache file and this and that, but still no joy, I even tried to delete TLD from my iMac, but still no joy, so I completely trashed Steam, and now re-installing it and TLD.

Will see what it brings up.

FYI, I played last night and there was nothing wrong, so it has happened with the update to .v 0.4. The file was either corrupt, or (ill soon see if its a TLD problem) with a re-install.

56ce09d38136f_Screenshot2014-07-0308.47.

Link to comment
Share on other sites

Glad to hear it's fixed, but I wonder what the root problem was. Let's keep an eye on this for the next update -- it's possible there is a problem with how we are delivering the updates for Mac.

Via a complete reinstall of steam though (glad I only had TLD on my iMac at this point in time).

As I said above, I went through the Steam FAQ/Troubleshooting, and got rid of the Apache File, and even got rid of TLD.app file but then Steam didn't recognise that it wasn't on my system anymore.

I have v.0.3 on my MBP, so ill see what I can do updating that to .v0.4, if I get the same problem, or not. Just a gut feeling, it felt like a corrupt download to me. When downloading, I looked and it was @48% after a couple of minutes, then when I checked a minute later it was complete . . . Seemed a little too quick, that last 52%

I am getting the same issue testing on my Macbook Air. Trying to nail down what can be causing it. It will be interesting to see if Raph gets this, as I know we didn't have this issue in the test branch.

If he does, he won't want to admit it haha ;)

Link to comment
Share on other sites

Ok -- finally had a chance to look into this.

Brent -- I end up with the same error as you for some reason. Deleted local files, re-downloaded, started it again, go the same error, closed it down, started it again, and it runs fine.

(Note that I did not re-install Steam. Just deleted local files for The Long Dark and re-downloaded it).

Have you been able to run it at all? I'm really perplexed as to what this is. We'll need to do more thorough testing on our Mac build before releasing it to you guys in the future... :(

Link to comment
Share on other sites

I did get it to run, by installing Steam again, because when I deleted the local files, Steam didn't recognised that they weren't on my Mac, because in the Steam Side Panel, it still had TLD as installed, and with the Play Button visible. I didn't start Steam or my Mac more than the 1 time, thinking all caches would of been cleared up on the 1st reboot.

I still haven't had time to mess around with updating my MBP Steam .v as of yet, but the weekend is coming so I will do this, then go and grab some logs and have a look through them.

Do you think it could be a Unity issue or more Steam and maybe a corrupt file during the update ?? But then again, it worked on the second start for you didn't it, so that knocks that out of the park . . . .

Ill update my MBP this arvo, or tomorrow morning (its my main computer so depends when I can get to it) and ill post back what happens.

I deleted the App from

Macintosh HD ▸ Users ▸ TattooedMac ▸ Library ▸ Application Support ▸ Steam ▸ SteamApps ▸ commo ▸ TLD.app

but wasn't recognised as not being there, even after restarting Steam . . .

Link to comment
Share on other sites

Brent -- I don't know all of Steam's inner workings, but my guess is it doesn't like it when people delete apps directly from their system.

To delete an app, right-click the game name in your Steam library, and select "Delete Local Content". This will remove all the local game files, and then you can re-download from the library.

When I first updated, I did notice Steam suddenly "hanging", on the last 7k or so. I was downloading 2MB/sec and then suddenly it choked on the last 7k, which seemed odd. But it appeared to complete the download.

We should try on another Mac that is going from v.03 to v.04 to see if we find the same behaviour. Definitely something odd going on. My uneducated guess would be that there's an issue with the "diff" Steam does when it compared the two versions.

Link to comment
Share on other sites

RAPH/Alan/Eric ~ [FYI this was on my Development MBP running Yosemite 10.10 Beta 0.2]

When .v0.3 came out, I installed steam and TLD on my MBP with 16BG RAM and a OWC Mercury Pro 6G 512GB SSD and it worked wonders. Ran beautifully, apart from the bugs that were present. I need to say this, so there is no confusion, and thinking it could of been the 10.10 Beta that caused the problems.

Anywho's, I went into Steam, and clicked on the TLD and by the time I got there, it was already in the (downloading stage siting on 0%) and the download Window popped up letting me know I could follow the download in the left column.

So I clicked finish to get out of that window.

It took Steam about 5-6 mins to actually start the download, sitting on 0% for that amount of time.

Once it started it downloaded anywhere between 1.4 and 2.2 MB/sec got to 99% but didn't hang for anything that wasn't normal.

All done and dusted, clicked play and the error came Straight Back up. The same one as in the OP.

I tried to restart my MBP, Steam a few times to see if it would clean caches and align everything, and finally done a Repair Disk Permissions and still no-joy :(

I then Deleted the Local file, via your instructions, downloaded it again, and clicked play and it work straight up, not errors, nothing ~ All good, so I didn't get the error the 2nd time like you did Raph ?? So . . . . . .

Link to comment
Share on other sites

Brent -- we all tried this internally on our Macs and all had the same error as you, and this was the only workaround we could find until we work out a proper solution.

In our testing, deleting local files (through Steam), and re-downloading the game, worked perfectly every time. There seems to be some issue with the updating from one version to the next that isn't working properly.

Just make sure you Delete Local Files in Steam, not manually from your system.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.