woodspiral

Graphics issues on MacBook when in full screen

Recommended Posts

Hi,

I haven't played TLD for a while and played it a couple of days ago.  Before running it updated to the Episode 3 version.  During the time I wasn't playing I also updated MacOS to Catalina 10.15.1.  Now, when I play the game in full screen mode the graphics are all glitched - there are horizontal blocks of colour around the edges and interlacing effects.  By tweaking the resolution down to around 800 x 600 (or thereabouts) it worked once, but after a restart it did not work again.  Running in a window, however, is totally glitch free and I can run the game at the highest resolution (it's a bit slow but it works fine).  Does anyone know why this is happening? It's a shame there was a game and OS update and I suppose it could be either that is responsible.   All other games and applications play fine in full screen mode.  TLD used to play fine in fullscreen before the Ep3 and OS updates.

System report follows:

====

  Model Name: MacBook Pro

  Model Identifier: MacBookPro13,3

  Processor Name: Quad-Core Intel Core i7

  Processor Speed: 2.7 GHz

  Number of Processors: 1

  Total Number of Cores: 4

  L2 Cache (per Core): 256 KB

  L3 Cache: 8 MB

  Hyper-Threading Technology: Enabled

  Memory: 16 GB 2133 MHz

  Boot ROM Version: 262.0.0.0.0

  SMC Version (system): 2.38f8

Graphics: 

Radeon Pro 455 2 GB

Intel HD Graphics 530 1536 MB

====

I went through the graphics trouble shooting tips on the support pages, but no luck.

Any clues appreciated.

Regards,
David.

 

Share this post


Link to post
Share on other sites
8 hours ago, Hawk said:

It is mentioned in this post that they are investigating this issue. ;)

 

Excellent, thank you, Hawk.  I confirm it's interaction with Catalina that is causing the issue - I downgraded to Mojave (10.14.4) today and the game is back to normal.  Perhaps there is a bug in Catalina.  I don't like this version of the OS anyway - Apple dumped the Dashboard.  Boo!

-David.

Share this post


Link to post
Share on other sites
26 minutes ago, woodspiral said:

Excellent, thank you, Hawk.

-David.

My pleasure. Glad it helped. :)

Share this post


Link to post
Share on other sites

Having this issue as well since Catalina. I don't really want to downgrade. I also performed the update available today 2019-12-11 and it still happens, no change. It is only fullscreen. If I start in windowed mode, then use the (+) button to go fullscreen it immediately starts happening, but when I bring up the border menu again (the border that on the top has the (X) (-) (+) buttons, or steam overlay it goes away. When the border slides back out of the way and it goes back to fullscreen the flickering comes back.

Man this is annoying. I've been using Nvidia GeForce NOW to play the game and have no issues while playing that way, but that always depends on a solid 50mbit connection to be smooth.

Please spend some time on this issue! I've been googling my brains out on it. All kinds of forums suggest its a vsync issue or a color depth but everything has been unhelpful.

It doesn't happen with any other game I play frequently. No other games do it so far (American Truck sim, Stardew Valley, Rimworld, Stellaris, Subnautica, Return of the Obra Dinn, Surviving Mars to name a few are all ok at full screen).

If it helps

MacBook Pro (15-inch, 2017)

Intel HD Graphics 630:

  Chipset Model:    Intel HD Graphics 630
  Type:    GPU
  Bus:    Built-In
  VRAM (Dynamic, Max):    1536 MB
  Vendor:    Intel
  Device ID:    0x591b
  Revision ID:    0x0004
  Automatic Graphics Switching:    Supported
  gMux Version:    4.0.29 [3.2.8]
  Metal:    Supported, feature set macOS GPUFamily2 v1
  Displays:
Color LCD:
  Display Type:    Built-In Retina LCD
  Resolution:    2880 x 1800 Retina
  Framebuffer Depth:    24-Bit Color (ARGB8888)
  Main Display:    Yes
  Mirror:    Off
  Online:    Yes
  Automatically Adjust Brightness:    No
  Connection Type:    Internal

 

Share this post


Link to post
Share on other sites

 

No glitches on my external monitor.

I just found out some additional information. I hooked up my external monitor (a 27" display for MAC) that I do not use very often. When connected to this external display it uses my Radeon Pro Graphics Processing Unit. And.. I get no glitches. The built-in Intel GPU I get glitches:

 

Intel HD Graphics 630:

  Chipset Model:    Intel HD Graphics 630
  Type:    GPU
  Bus:    Built-In
  VRAM (Dynamic, Max):    1536 MB
  Vendor:    Intel
  Device ID:    0x591b
  Revision ID:    0x0004
  Automatic Graphics Switching:    Supported
  gMux Version:    4.0.29 [3.2.8]
  Metal:    Supported, feature set macOS GPUFamily2 v1

 

But the external GPU, no glitches:

 

Radeon Pro 560:

  Chipset Model:    Radeon Pro 560
  Type:    GPU
  Bus:    PCIe
  PCIe Lane Width:    x8
  VRAM (Total):    4 GB
  Vendor:    AMD (0x1002)
  Device ID:    0x67ef
  Revision ID:    0x00c0
  ROM Revision:    113-C980AJ-927
  VBIOS Version:    113-C9801AU-A02
  EFI Driver Version:    01.A0.927
  Automatic Graphics Switching:    Supported
  gMux Version:    4.0.29 [3.2.8]
  Metal:    Supported, feature set macOS GPUFamily2 v1
  Displays:
LED Cinema Display:
  Display Type:    LCD
  Resolution:    1920 x 1200 (WUXGA - Widescreen Ultra eXtended Graphics Array)
  UI Looks like:    1920 x 1200
  Framebuffer Depth:    30-Bit Color (ARGB2101010)
  Display Serial Number:    xxxxxxxxxxxxxx
  Main Display:    Yes
  Mirror:    Off
  Online:    Yes
  Rotation:    Supported
  Automatically Adjust Brightness:    No
  Connection Type:    DVI or HDMI
  Adapter Firmware Version:    7.95

 

Not sure if it helps, but usually the more info, the better.

Edited by lore-nmj

Share this post


Link to post
Share on other sites

Is there a way to tell your mac that you want to use the radeon adaptor while using the built-in screen, or is it only available when using an external monitor?

tbh I'm not that surprised that the intel graphics chipset isn't fully up to the job of running the game... if you have a way to tell your system that you want to use the radeon for now, or even better tell it to use it for particular applications (like TLD) that'd work. If you're strictly tied to using the intel adaptor while using the laptop's built-in monitor then you're kind of boned for running it without an external monitor.

 

Share this post


Link to post
Share on other sites
On 12/16/2019 at 1:04 PM, stratvox said:

Is there a way to tell your mac that you want to use the radeon adaptor while using the built-in screen, or is it only available when using an external monitor?

tbh I'm not that surprised that the intel graphics chipset isn't fully up to the job of running the game... if you have a way to tell your system that you want to use the radeon for now, or even better tell it to use it for particular applications (like TLD) that'd work. If you're strictly tied to using the intel adaptor while using the laptop's built-in monitor then you're kind of boned for running it without an external monitor.

 

I have been playing this game for years without being boned. I don't know of a way to select the graphics adapter being used and I would suspect it is tied to using an external monitor. something caused a change. An update from Hinterland? An update from XCode? (I'm a developer) An update from SDL2 Library?  I wish someone could tell me. And yes, with the latest update today (2020-01-20) it is still happening and it makes the game unplayable. I play with an intel graphics card at work, but on Linux and it works fine.

  • Upvote 1

Share this post


Link to post
Share on other sites

Hmmm. I'd take a look at a recent driver update from Apple as being the culprit for that. It's also possible Hinterland have added some graphics features to the game that are now pushing your intel card beyond its capabilities. Have you tried turning down things in the "Quality" section of settings to see if it helps with the glitching? I'm not very familiar with Macs so it's hard for me to comment. Maybe cast an eye at this page from Apple: https://support.apple.com/en-us/HT202043 and in particular consider taking a look at the two related pages linked at the bottom of this article.

Share this post


Link to post
Share on other sites

Same as lore-nmj, I find the game unplayable at the moment as well. Tried contacting support and using twitter channels - but not heard anything back. I appreciate the difficulty in keeping everything working on all platforms, but its been over 2 months now since ep3 dropped and the issue was acknowledged in the post release notes - it would be nice to some form of update on this.

I really don't want to be one of those people that leaves a crap review on Steam for what I know is a good/great game - but if you can't play it on a platform, its difficult not to warn people.

@stratvox - when the game starts up the UI is all pixelated. The only thing you can really do if you know the interface is navigate to the Quit option to exit the game, nothing else is clear. If you watch the Activity Monitor for the app process, you can see its not running on the GPU, but on the Integrated graphics chip - and tbh I'm not sure there is a way to force OS X to use one over the other - or if you should.

Share this post


Link to post
Share on other sites
On 1/20/2020 at 6:07 PM, stratvox said:

Hmmm. I'd take a look at a recent driver update from Apple as being the culprit for that. It's also possible Hinterland have added some graphics features to the game that are now pushing your intel card beyond its capabilities. Have you tried turning down things in the "Quality" section of settings to see if it helps with the glitching? I'm not very familiar with Macs so it's hard for me to comment. Maybe cast an eye at this page from Apple: https://support.apple.com/en-us/HT202043 and in particular consider taking a look at the two related pages linked at the bottom of this article.

I will give that setting a try if I can find it. Since it is related to battery life and I play while plugged in, I'm not sure it has anything to do with it. But, it is a setting and worth trying. Thanks.

I will update here with my findings.

Also, the menu system is so badly pixelated and the graphics flicker so badly  I can't tell what is on the screen. I was able to get it to go in non-full screen mode, which makes play so bad that it is like a 1/4 or less of your framerate - unplayable - in other words, but it does allow you to navigate the menu system clearly. In, non-full screen everything is perfect - just lags so bad it is unplayable.

 

Update:

I tried it. No change. Still glitchy graphics.

Edited by lore-nmj
I tried it. Here are the results.

Share this post


Link to post
Share on other sites

I tried the update. 1.73. The issue still persists.

However, I did learn something.

I started up Quicktime in order to use it's screen recording feature to see if I could capture the flickering/flashing problem. Then I started up the game like normal. I have to start in Windowed mode otherwise I can't see the menu due to the problem. It is guaranteed to happen though even in the main menu when I click the '+' sign on the game window to make it full-screen. However, it doesn't happen while I am screen recording.

I'm guessing this is because something is interfering with the normal process of graphics information. The screen recording plugin is likely causing the graphics writes to the screen to happen differently.

But, for whatever reason, it fixes the issue.

To summarize, it still occurs only with the onboard graphics (Intel HD Graphics 630 1536 MB), not with the graphics card that drives an external monitor (Radeon Pro 560 4 GB). However, it does not occur while screen recording with the use of QuickTime. I did not try OBS, but I can if that helps.

This isn't a fix because screen recording takes a huge amount of processing power and drops my framerate to a quarter of what I would usually get. Makes the game unplayable at my normal settings. But.. interesting, no?

Share this post


Link to post
Share on other sites

You don't need an external monitor to activate the discrete graphics gpu (radeon in your case), just go to the energy saver panel in system preferences and uncheck automatic graphics switching, this way your macbook will always use the discrete gpu. 

Share this post


Link to post
Share on other sites

I just checked and this worked. It does not offer a selection for you to pick. It simply says: The higher performance graphics card will be used. It loads the game and I can go to full screen.

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now