Performance Issues and Loss of all progress


Recommended Posts

Hi, I've been playing the game for 2 years now and this this summer I upgraded my GPU from a 1080 to to 1080ti (EVGA Superclocked 2) and for some reason recently I started seeing issue in my sandbox game. Extreme stuttering and a kind of jerky camera effect when moving and looking around . I'm running everything maxed out as I did before upgrading my GPU. I have an Intel i7 6700K overclocked to 4.5ghz, 16gb DDR4 Ram and I'm running the game at 21:9 at 3440x1440p on a Gysnc 100hz monitor. Obviously running the game with everything maxed out at that resolution is demanding but it worked perfectly with the 1080 at the same settings befoire. I tried toggling some settings with no luck. I've had no problems with any other games at all. Today I decided to try and uninstall and reinstall the game to see of that helped. Unfortunately, upon relaunching the game I found ALL my progress from story mode (eps 1 and 2 completed), all my feats and progress towards new ones, and all my previous journals and stats have completely gone. I even started a new sandbox and also found the same technical problems as before as well. I've 'moved' my game once 18 months ago from an iMac running bootcamp to the PC I built and didn't lose any progress then. Any help would be greatly appreciated as I have more than 175 hours logged on Steam and this is obviously a pretty depressing turn of events:(

Edited by WeAreTheDark
Link to post
Share on other sites

Uninstalling the game deleted all of your saves, as it presumably would. If you don't use Steam cloud backup, then it's gone. Sad, but true. As for your performance issues, I think it's pretty clearly an issue with the new card or drivers.

Link to post
Share on other sites
24 minutes ago, Carbon said:

Uninstalling the game deleted all of your saves, as it presumably would. If you don't use Steam cloud backup, then it's gone. Sad, but true. As for your performance issues, I think it's pretty clearly an issue with the new card or drivers.

I use Steam cloud as a matter of course. As I said, I was able transfer my game from PC to PC using this method. As for my new card and drivers. All correctly installed and up to date. This is only game I have experienced these issue with (incl some pretty performance heavy AAA games like Dishonored 2, Prey, Watch Dogs 2,  Titanfall 2 and Hitman ).

Link to post
Share on other sites
  • 1 month later...

Yeah, I'm also getting this (or a similar) issue - only when going in between regions and loading indoors/outdoors. It's obviously some kind of bug and not a normal performance issue. Firstly, because my hardware can manage the game easily at around 100FPS at all times and secondly, because when I switch out of the game for a second by pressing the windows key, and going back in, everything's fine again.

BTW, 'performance drops' is a mild word, it's actually completely breaking down to a stutter fest going between 15 and 80 FPS, even when not moving. Absolutely not playable.

The thing is: I remember this exact issue from when I last played the game, maybe a year ago. However, back then it only happened sometimes, not everytime I go inside/outside. Back then I always had to quit the game; not sure if I tried just tabbing out and back in again.

Are the devs aware of this issue? Or do only few people have it?

Link to post
Share on other sites

My issues have been resolved. I rebuilt and reinstalled the OS, Windows 10. Reinstalled and made sure my drivers were up to date. Not even a fresh, clean, and updated driver install fixed it. I tried to look into something that I would never suspect, my CPU. After some research I decided to try a fix from fellow 6-core owners: Disable Speedstep. It worked.

This game needs to be optimised a bit better. Even now that the game is fixed and running well for me, the performance scale is subpar. My GPU usage maxes out at 50% while I can only see 2 threads using any more than 30% usage in the CPU department with the rest ranging from 5% to 20%. It’s nearly 2018, not 2008. At least start with enabling 64bit execution.

Link to post
Share on other sites

Hm, so SpeedStep was the issue for you? But it's no solution to disable it; that'd mean burning max energy at all times, wouldn't it? Other games don't have these issues, so it must be doable without disabling Speedstep.

My GPU (a GTX 1070) is actually hitting 100% in this game and getting rather hot (79 degrees C is alright, I guess, but in most games it never goes beyond 75).
Anyway, like I said, I have no performance issues except when there is a transition.

Link to post
Share on other sites
20 hours ago, MaxximusD said:

At least start with enabling 64bit execution.

That worked for me out of the box with zero configuration on my part... but I'm running it on linux. Linux has long been advantageous wrt 64 bit and unity; it's only recently that the Windows side of unity caught up to that. See for example the travails the KSP on windows community had with that for years while I was running x64 with ease.

 

12 hours ago, Ego_Bizarro said:

Hm, so SpeedStep was the issue for you? But it's no solution to disable it; that'd mean burning max energy at all times, wouldn't it? Other games don't have these issues, so it must be doable without disabling Speedstep.

I'm wondering if maybe that's specific to six core as mentioned by MaxximusD. I've got an eight core and it's not been a problem in any way.

Again, running linux... ymmv and all that.

Link to post
Share on other sites

Interesting. I'm running a 1060 and it doesn't seem to pound my GPU hard. I'm topping out at about 60-65C. I generally run performance mode speed step, but I've switched to powersave mode and I'm not seeing graphics glitches. I have found a graphics glitch when harvesting carcasses (and which I've reported as a bug). I'm wondering if maybe your graphics problems are map specific?

Link to post
Share on other sites
On 12/7/2017 at 9:00 PM, Ego_Bizarro said:

Hm, so SpeedStep was the issue for you? But it's no solution to disable it; that'd mean burning max energy at all times, wouldn't it? Other games don't have these issues, so it must be doable without disabling Speedstep.

My GPU (a GTX 1070) is actually hitting 100% in this game and getting rather hot (79 degrees C is alright, I guess, but in most games it never goes beyond 75).
Anyway, like I said, I have no performance issues except when there is a transition.

Actually. When I had major issues before I disabled SpeedStep, while TLD was experiencing major issues as I described below, the rest of my games were "fine". What I noticed after I made this change with disabling SpeedStep was that the rest of my games weren't "fine". Even before the change the FPS and CPU/CPU utliziation on these games are high, once I made the change all my other games became buttery smooth. So it made me realise that this setting fixed a minor issue for me that I hadn't realised. Frametime issues perhaps, but barely noticeable. Only when after I made the change suddenly these games were buttery smooth.

On 12/8/2017 at 9:45 AM, stratvox said:

That worked for me out of the box with zero configuration on my part... but I'm running it on linux. Linux has long been advantageous wrt 64 bit and unity; it's only recently that the Windows side of unity caught up to that. See for example the travails the KSP on windows community had with that for years while I was running x64 with ease.

 

I'm wondering if maybe that's specific to six core as mentioned by MaxximusD. I've got an eight core and it's not been a problem in any way.

Again, running linux... ymmv and all that.

It could be. As much as I hate Windows 10, it's my preferred gaming platform. These God damn updates keep messing up my rig, even in a minute way it bothers me since I've got a high powered PC.

Link to post
Share on other sites

All my other games ARE running absolutely smooth as butter, really.

And you might get a shock on your next electricity bill because if I understand SpeedStep correctly, your PC runs at full power at all times now, even when idle.

Also, I'm pretty sure SpeedStep is not the issue, because first of all, it's not all the time but only when there's a transition. And secondly, what I'm getting is not just normal low performance. If it was that it should pretty much stay in one place (like, around 20 FPS or something), especially when not moving or looking around. But it's a weird stutter fest and FPS are jumping around between 15 and 80 FPS.

In the end, I'm pretty sure it's a bug in the game engine and I really hope Hinterland fixes it. I love this game but tabbing in and out kinda kills the immersiveness. (good thing I'm lost somewhere on Timberwolf right now where there seems to be NO place whatsoever to get inside, so no transitions and I get the problem only sometimes after loading my save game.)

Link to post
Share on other sites

What's your CPU? I was sceptical that it wouldn't work for me but I felt like I'd exhausted most of my options.

Just to give an indication, this isn't a unique incident. This is just one search filter:

https://www.google.com.au/search?q=game+stutter+disable+speedstep&rlz=1C1CHXU_enAU717AU717&oq=game+stutter+disable+speedstep&aqs=chrome..69i57j0j69i60j0l3.9831j0j7&sourceid=chrome&ie=UTF-8

I wouldn't even mention it, let alone try it but as I said, I was out of options.

Link to post
Share on other sites

Intel i5-4690k

If you say it got fixed by disabling SpeedStep , I believe you.
However, that's no fix for me. That's something Hinterland has to fix. I can't have my PC running at full power all the time.
Until it's fixed, tabbing in and out is the better workaround for me.

Link to post
Share on other sites

Hey! So, it SEEMS like my issue just went away!
I don't know if one of the recent updates did anything...
The only other explanation is that I recently reinstalled Win10. I didn't think the issue was on my end because 1. I've had it before a long time ago (even before the creator's update) and 2. my system normally runs very smoothly with no issues in games whatsoever.

Either way, I couldn't tell for some time because I've been on Timberwolf Mountain where I didn't have any 'going in/outside' transitions. But now that I'm back in Pleasant Valley, I've entered and left buildings without any problems.

So, I'm hoping this is it then. Just wish I knew what exactly the problem was.

Link to post
Share on other sites
  • 4 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now