Rivent

Just bought the game, and having a big problem with stuttering

Recommended Posts

I just bought The Long Dark yesterday, and when I attempt to play it I'm having a problem with the game "stuttering". It happens on the main menus, as well as in the game itself. Every 5-10 seconds the game will basically completely freeze for 3 seconds or so, then it begins running normally for another 5-10 seconds until it happens again. It's completely unplayable in this state because the stuttering is so consistent and the "hangs" last so long. I'm running Windows 10 on a desktop with an i5 3570, 16GB of RAM and a GTX980, and all my drivers are up-to-date.. In-between the stutters the game seems to run completely smoothly. I've tried disabling the Steam overlay, as well as running in DX9 mode instead of DX11, but neither of these seemed to have any effect. I've checked my performance tab while the game stutters and does it's thing and there are no spikes indicating the hardware is being taxed heavily or anything while they happen. Wondering if this is a known issue with any kind of fix, but if not I at least wanted to bring it to the dev's attention. 

Share this post


Link to post
Share on other sites

Greetings @Rivent!

8 minutes ago, Rivent said:

I just bought The Long Dark yesterday, and when I attempt to play it I'm having a problem with the game "stuttering". It happens on the main menus, as well as in the game itself. Every 5-10 seconds the game will basically completely freeze for 3 seconds or so, then it begins running normally for another 5-10 seconds until it happens again. It's completely unplayable in this state because the stuttering is so consistent and the "hangs" last so long. I'm running Windows 10 on a desktop with an i5 3570, 16GB of RAM and a GTX980, and all my drivers are up-to-date.. In-between the stutters the game seems to run completely smoothly. I've tried disabling the Steam overlay, as well as running in DX9 mode instead of DX11, but neither of these seemed to have any effect. I've checked my performance tab while the game stutters and does it's thing and there are no spikes indicating the hardware is being taxed heavily or anything while they happen. Wondering if this is a known issue with any kind of fix, but if not I at least wanted to bring it to the dev's attention. 

Have you tried turning VSync on or off from the Options menu in the game?

Share this post


Link to post
Share on other sites

If @Timber Wolf's suggestion doesn't work, you might try going into your Steam library and having it verify the game files. It's always possible that something borked during download.

Share this post


Link to post
Share on other sites

Yeah, I've tried messing with all of the graphics options, including VSync. I've also tried verifying the files on Steam and even re-downloading the game. No luck.

Share this post


Link to post
Share on other sites

Thanks for the suggestion, @Timber Wolf. I gave it a shot, but it didn't fix the problem, unfortunately. 

Edited by Rivent

Share this post


Link to post
Share on other sites
13 hours ago, Rivent said:

Thanks for the suggestion, @Timber Wolf. I gave it a shot, but it didn't fix the problem, unfortunately. 

Ok, my one last thought is about your hard drive.  You didn't include the specs above.  Everything else you have is up to date, but I thought I'd ask anyway.  If it is a newer drive, then it's not likely the issue.  But if you are running the game off an older drive, that could be the issue.  If not, I'm afraid I've run out of ideas.  :(

Share this post


Link to post
Share on other sites

Yeah, it's definitely not my drive. I just bought a new SSD a year or so ago, and everything else runs perfectly on it. I actually even reformatted my whole machine this morning just to see if some unforeseen setting/OS issue was causing it, but it's still happening. Oh well... 

Edited by Rivent

Share this post


Link to post
Share on other sites

Attaching my output_log just in case the devs stumble into this thread. I saw them request it in the Steam technical forums for another issue, and I'm completely out of ideas.

output_log.txt

Edited by Rivent

Share this post


Link to post
Share on other sites

There is nothing in the log that would suggest a problem. I've read this thread several times and there isn't anything I can spot as an obvious issue. So far the steps taken have been exactly the same that I would suggest, but maybe we can dig deeper into this.

I want to try a couple things, first can I get you to run the game in windowed mode while running the task manager->performance tab - I'd like to see if there are any obvious connections between unusual performance and the game. 

Do you play any other Unity based games by chance? 

Any software running in the background, such as capture or antivirus/malware software? 

Share this post


Link to post
Share on other sites

Thanks for the reply, @Support. I have run the game with the performance tab in task manager up on my second monitor, and when the game hangs there are no obvious spikes in any of my hardware usage. 

Background software: Skype, Dropbox, Onedrive, Google Drive, Geforce experience, Logitech Gaming Software and Windows Defender. I've tried disabling Windows Defender and closing Geforce experience, and that didn't fix the problem. I never thought to do it until listing out my background software, but I also just tried closing Dropbox, Google Drive, Onedrive, Skype, and Logitech and that didn't have an effect either.

Unity games I've played on this PC (I'm going by a list of Unity games on Wikipedia, so I apologize if some of these aren't actually on Unity): Gone Home, RimWorld, Shadowrun Returns/Dragonfall, Hearthstone, Jazzpunk, Wasteland 2, Cities: Skylines, Ori and the Blind Forest, Inside and Superhot. The only issue I've had with any of them was that I had to disable my second monitor when playing Superhot, otherwise it would run terribly for some reason. Once I disabled the monitor, it ran perfectly smoothly. I also tried this for The Long Dark, with no success.

EDIT: Just as further troubleshooting, I tried a couple more things today. I entered -force-d3d9 to the Steam launch options to force the game in to DirectX 9 mode, and when that didn't work I changed that back and tried moving the game from my SSD to one of my other hard drives using a program called Steam Mover. The game was successfully moved, but the problem persisted.

Edited by Rivent

Share this post


Link to post
Share on other sites

Hey,

I've got nearly the same problem. Just noticed that the game continues after a few seconds of freezing but then it freezes again, like Rivent already described.

Furthermore some textures are purple during the lags. 

Tried a lot. Nothing helped.

Regards,
Lehmboden
 

 

Share this post


Link to post
Share on other sites

The issue seemed nearly fixed for a while yesterday. The lock up that was lasting several seconds at a time was reduced to a simple stutter, dropping me from 60 frames per second down to about 35-40 for half a second, and then immediately recovering. The game was relatively playable during this time. No changes had been made to my computer/drivers/etc... Today, the original issue has returned and I'm unable to play. What a strange issue...

Share this post


Link to post
Share on other sites
5 minutes ago, Rivent said:

Today, the original issue has returned and I'm unable to play. What a strange issue...

Are you running CrashPlan?  Or another backup service like that?

Share this post


Link to post
Share on other sites

This is a very strange issue - The fact that cleared up but returned later is very curios. We didn't release any patches or anything of that sort.

Just to check, have you also made sure your Video Card isn't throttling for some reason? I had an issue with my 980ti where it would throttle down as the EVGA default fan settings actually had them idle, so a temp spike would trigger the throttle warning. Forcing my fans to run at a minimum at all time fixed the issue. Not sure if it's similar to your issue, but at this point there isn't a lot more to go off of, unfortunately. 

Share this post


Link to post
Share on other sites

Sorry for the late reply, @Support, it's been a bit of a busy week. My video card isn't throttling, I checked all of that when I first noticed the issue. Like you, I'm pretty much baffled. There doesn't seem to be any logical reason as to why this would happening, even moreso after it started working (well, at least better than it had been) for a little while and then reverted back to it's previous behavior. I'm completely out of ideas other than "Sit and wait and hope a future game or driver update accidentally fixes the issue". 

Share this post


Link to post
Share on other sites

Thanks for the follow-up. This is something we're going to continue to monitor on our end as well. My home PC is very similar to your system so I'm hoping I can emulate the issue and get some info on what might be causing this. 

  • Upvote 1

Share this post


Link to post
Share on other sites

If there's anything else you want me to try on my end at any point, feel free to ask. I'm a software/data QA engineer (though not for games) so I do have some experience with things going wrong that never should in the first place, and trying to troubleshoot the problem. I'll keep checking back in periodically. 

Share this post


Link to post
Share on other sites

I know i'm really late, but disabling the steam overlay (Properties > General tab) for The Long Dark fixed the stuttering for me. 

Share this post


Link to post
Share on other sites

This might sound weird but i had a little stuttering and oddly then when i turned up all the settings in Graphics to maximum including Draw distance it actually ran smoother, which didnt make sense but fixed it. I had no stuttering after.

One other thing you might try is :

Open your 'NVIDIA Control panel' . Then choose 'Manage 3D settings'.Then 'program settings' let it load itself up and list all your programs. Then where it says ' select a program to customise' and a drop down box, scroll down and find The Long Dark exe. The you will see a list of more options. Go to ' Power management mode' The game is likely default set to 'Use global settings ( Optimal power)' . click that box and try instead ' Prefer Maximum Performance' . I find this sometimes fixes laggy or struggling games a bit.

 

Not sure if either of these ideas helps at all.

Share this post


Link to post
Share on other sites

@Support Just FYI, the most recent update(s) seem to have fixed this issue for me. I played a couple of weeks ago (pre "Faithful Cartographer") and the stutter had been reduced to the relatively playable micro-stutters I described as happening once or twice early on with this issue. But after this recent update, the game runs completely smooth for me. I'm not sure what changes happened to fix the issue, but I wanted to at least let you know that this very strange problem, in my case, is resolved. 

Thanks to everyone else for the suggestions as well. Excited to finally be able to check this game out.

Edited by Rivent

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now