Eames

Screen tearing/glitching since v364

Recommended Posts

  • OSX 10.11.6
  • Radeon HD 6750M
  • 2.5 GHz Intel Core i5

Ever since Vigilant Trespass beta, there's those weird graphical glitches for a millisecond when looking around outdoors. They don't happen indoors and they don't happen if viewport doesn't move.

582f4133e0ed3_Screenshot2016-11-18at19.4582f41553dcd5_Screenshot2016-11-18at19.4Screenshot_2016-11-18_at_19.45.26.thumb.582f4191edd89_Screenshot2016-11-18at19.4582f41aca7a7b_Screenshot2016-11-18at19.4Player.log

Edited by Eames
  • Upvote 2

Share this post


Link to post
Share on other sites

The update changed lots of textures, maybe this has something to do with it.

Share this post


Link to post
Share on other sites

That looks like graphical corruption, and not screen tearing - First thing to do is to uninstall the game, then reinstall it from scratch. These generally point to a render error as the vertices are blown out, reinstalling will ensure that there are none that are corrupted. There is nothing in the log that suggests the error, so by first stop would be local files. 

  • Upvote 1

Share this post


Link to post
Share on other sites

I am completely frustrated by the lack of effort to solve this problem. This has been going on since the Vigilant Trespass beta and the game is really unplayable in this condition. Now they are beta testing another release without any fix for this problem from the last release... What happened Hinterland? You guys were always on top of these things in the past now your behaving like the rest of the game developers out there, little or no response and it's been months now.

  • Upvote 1

Share this post


Link to post
Share on other sites

Maybe they just can't reproduce the problem or maybe it happens to so few people that it's understandably not a priority.

Edited by Eames

Share this post


Link to post
Share on other sites

Same problem and also the trees constantly has been getting glitches on around. It was rarely happening earlier but now it beginning immediately after a while. I tried everyting to fix it but didn't fix yet.

  • Upvote 1

Share this post


Link to post
Share on other sites

To be honest I don't think they are even looking at it. I have seen several people with the exact same issue post it on this forum and I have seen three responses from support and each one was vague. Obviously it has something to do with the Vigilant Trespass update. All the postings have stated as much so why not begin there.

 

If nothing else let me revert back to the previous version so I can play, or give me my money back...

  • Upvote 1

Share this post


Link to post
Share on other sites
On 11/25/2016 at 5:00 PM, Support said:

That looks like graphical corruption, and not screen tearing - First thing to do is to uninstall the game, then reinstall it from scratch. These generally point to a render error as the vertices are blown out, reinstalling will ensure that there are none that are corrupted. There is nothing in the log that suggests the error, so by first stop would be local files. 

This is a completely different response than the one I got which was basically "it's your hardware not our game". That's obviously not the case since it is being reported by others and they obviously just aren't really looking at it.

  • Upvote 2

Share this post


Link to post
Share on other sites

No it's not a completely different response, the reason I'm asking for these steps is to do everything we can to make sure it's not hardware. Reinstalling does solve these issues for many Users, but not all. It's also why it's a standard step in our FAQ. It often eliminates general software issues. If someone has already reinstalled the game or tried similar fixes like reinstalling drivers, etc - I can't do much else other then get the log. When the log doesn't contain errors there is little for us to go off of. However graphical issues like these do generally manifest from hardware or driver issues. This also fits with the pattern of the error-less logs. However, we've continued trying to reproduce this in-house but have not been able to, as of yet. Simply because I don't have much more information to go off of I can't offer much more information. 

We have have a test build out right now that does contain some general rendering improvements. Because we have not been able to reproduce these issues I can't guarantee that this will offer any solution, but it's worth the shot. These fixes will also be in the Update once the Test Branch is done. This build also fixes the purple tree issue, which makes DX9 mode an alternative again, which may address this issue.

Share this post


Link to post
Share on other sites

What have I tried for fix this issue ?

Formatted my hard drive, I bought new motherboard, graphics card, ram, hard driver and cpu. Still it didn't fix. Is it hardware problem or software problem ?
 

Share this post


Link to post
Share on other sites
On 03/12/2016 at 0:42 AM, ByST7 said:

Formatted my hard drive, I bought new motherboard, graphics card, ram, hard driver and cpu. Still it didn't fix. Is it hardware problem or software problem ?

Care to share what you bought? This is not a widespread issue by any means, so knowing what hardware/software you're running this on helps shed some light on why you're experiencing the issue. 

 

On 11/12/2016 at 3:55 AM, Eames said:

Still there in V.381T

Did you try running the game in DX9 mode? 

Share this post


Link to post
Share on other sites
15 hours ago, Support said:

Did you try running the game in DX9 mode?

Can't do that - OSX.

I found if you do full look around, it stops glitching until you move somewhere else.

Edited by Eames

Share this post


Link to post
Share on other sites

Use DDU to clean your GPU drivers/registry and reinstall them. Might not be enough to simply do a software upgrade, even if you upgrade your hardware. Something may have been left behind. Do you own any other Unity games that might have issues?

Share this post


Link to post
Share on other sites
1 hour ago, ThatDearGuy said:

Use DDU to clean your GPU drivers/registry and reinstall them. Might not be enough to simply do a software upgrade, even if you upgrade your hardware. Something may have been left behind. Do you own any other Unity games that might have issues?

DDU is a windows application. OP is running a Mac on OS X.

Wild anecdotal speculation on my part here, but I feel like at v.364/365 an update has been done on the Unity engine being used by TLD resulting in a number of issues for older card/drivers in OS X. 

Share this post


Link to post
Share on other sites

Right, right. OSX. Sorry. Maybe there is a DDU equivalent?

Come to think of it, it's sorta odd to have PC and Mac grouped together in a forum. Hm.

Edited by ThatDearGuy

Share this post


Link to post
Share on other sites

Have found a workable solution that while it dos not solve the problem entirely, it does eliminate some of the problem. Enough so that i can once again play the game with far less graphics issues.

I was running the game at 2560 x 1440 resolution, when i switched to 1920 x 1200 I found that the problems occurred much less and i could play the game with some graphic anomalies but not enough to make it unplayable. Maybe support has an idea as to why this is the case.

Again the game worked perfectly until the vigilant trespass update and then these problem began and continued into the new update. Only after switching the screen resolution did i get some improvement.

I am using a MAC specs below.

Screen Shot 2016-09-23 at 8.53.53 PM.png

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.