Raf109

Game performance

Recommended Posts

The game got quite laggy after I changed my graphics card. And I'm not sure if the game is optimized for my current graphics card or not. I mostly get around 14-24FPS.

I get a lot of lag at; Outdoors and Indoors (especially large indoors such as Hydro Dam), blizzards, wind that makes the trees shake, fire or anything related to general light sources.

There was only some moments where I got a solid 30FPS indoors.

The game is on the lowest setting and I'm playing with a low resolution at fullscreen. And yes, I tried windowed.

Is there anything I can do to improve the performance of the game? My computer does a good job at keeping other games around 30FPS.

I'll post my PC specs if necessary. Btw, I was using an Nvidia graphics card before.

Cheers.

Share this post


Link to post
Share on other sites

I most certainly will need to know your current system specs before I can make any suggestions on how to improve performance. 

Share this post


Link to post
Share on other sites

Intel(R) Core(TM) i3-3240 CPU @ 3.40GHz

RAM: 8.00 GB

Graphics card: amd radeon hd 5450

Share this post


Link to post
Share on other sites

The most I can recommend at this point would be to try to run the game in DX9 mode, as that disables some of the higher cost rendering options (there is a batch file that will do this for you in the TLD install directory.) The problem is your CPU is below min spec and your GPU is arguable below min or right at min spec. 

Share this post


Link to post
Share on other sites

I see tld_dx9 and tld_borderless_dx9

What do I do with it?

Share this post


Link to post
Share on other sites

Just double click the tld_dx9 one. The second one runs the game in boarderless fullscreen, which probably not what you want for this situation.

Also if you didn't reinstall windows when you upgraded your video card, you may want to consider that as old drivers, especially those from a different vendor, can cause issues. 

Share this post


Link to post
Share on other sites

The game is working a little bit smoother now, I've had the new video card for about 3-4 months and I didn't have any issues with the drivers, I'm sure they are updated and working properly.

Thanks for your time, If I could only shake your hands from here...:big_smile:

Share this post


Link to post
Share on other sites